[Controller] Avago 530-8i 크로스플래싱 완료

   조회 1554   추천 1    

 


정상 인식 되네요. 이제 실제로 SSD를 잘 인식하나 테스트만 해보면..


짧은글 일수록 신중하게.
간장게장 02-17
SAS는 당연히 잘 되리라 생각합니다. cross flashing 하지 않아도 원래 되는 것이니...

SAS3408 tri-mode 칩을 사용한 adapter에 firmware까지 LSI의 것으로 바꿨으니 NVMe도 될 것 같은데요. 정말 되는지 안되는지는 붙여보아야 아는 것인데, 무척 궁금합니다.

Lenovo 530이나 Dell 740P나 모두 tri-mode 되는 칩을 쓴 것이지만 NVMe 된다는 말은 한마디도 없어서리.
LSI OEM 제품들이 raid 0, 1, 10만 되고 raid 5는 안된다든지, raid 5까지만 되고 raid 6는 안된다든지 하는 식으로 일부러 막아 놓고 기능을 on 시키려면 따로 licence key를 꼽아야 되도록 만들어 놓은 것들이 많은데요.
SAS3408에서 NVMe 지원 기능을 OEM firmware로만 막아 놓은 것인지 하드웨어적으로 막아놓은 것인지 모르겠습니다.
     
송주환 02-17
SSD가 조만간 도착할 것입니다.
도착하면 붙여보고 후기 올리겠습니다.
     
LSHLSH 02-17
일단 9400계열로 변신되면 다 될거 같네요. 애초부터 raid모드에서는 nvme가 안되게끔 되어 있어서 일단 칩셋레벨에서는 그거까지 막지는 않았다고 알고있습니다.
간장게장 02-20
lsi 9400 계열 tri-mode HBA(9400-8i, 9400-16i, 9405w-16e 등) 혹은 RAID card(9460-8i, 9460-16i)에 관한 정보가 인터넷을 검색해 보아도 많지 않습니다.
나온지 꽤 오래되었음에도 불구하고 리뷰기사도 없는 것 같고, 성능 테스트를 해 본 개인 리뷰도 거의 없는 것 같고요.

https://forums.servethehome.com/index.php?threads/new-lsi-9400-series-nvme-hba.13430/#post-151871

이 글에 의하면 tri-mode 아답터로 NVMe를 사용하려면 특별한 케이블을 필요로 하는 것 같기도 합니다.
일반적인 SFF-8643 to SFF-8639로는 안된다는 것인지 모르겠습니다.

* SFF-8643 to SFF-8639
https://www.ebay.com/itm/0-5m-Durable-U-2-SFF-8639-to-HD-Mini-SAS-SFF-8643-Cable-for-2-5-SSD/323685592961

그럼 이 케이블 쓰는 사람들은 NVMe 아답터를 LSI 외의 다른 것을 사용핟다는 말인가?

하여간 저 위 링크에 나온 이야기를 보면 LSI tri-mode 아답터에서 NVMe SSD를 쓰려면 LSI에서 나온 특별한 비싼 케이블을 써야 한다는 것 같습니다.
cable (PN:05-50065-00)

찾아보니 이런 케이블인데요.
https://www.pc-pitstop.com/sas_cables_adapters/055006500-nvme.asp
https://www.span.com/compare/05-50065-00-vs-CBL-SFF8087OCF-05M/64256-7875

SFF-8643으로부터 2개의 SFF-8639를 연결하도록 되어 있는 케이블입니다. 무척 비싸네요.
SFF-8639 쪽은 분명히 커넥터가 2개인데, SFF-8643쪽은 x4 하나에 연결하는 것인지 x4 2개에 연결하는 것인지 확실히 모르겠습니다.

게다가 어떤 사람이 올린 글을 보니 비싼 돈 주고 LSI의 tri-mode 케이블을 사서 NVMe SSD를 연결해 보니 속도가 구리다는 이야기가 있네요.
https://forums.servethehome.com/index.php?threads/poor-nvme-performance-on-broadcom-9440-8i-lenovo-530-8i.23534/#post-219411

PCIe 컨버터에 연결하면 제 속도가 나오는데, 9440-8i에 LSI 케이블을 연결하면 속도가 구리게 나온다고.
이 사람이 세팅을 잘못한 것인지 뭐 다른 이유가 있어서 그런 것인지는 아직 알 수 없습니다. 단 한 사람의 경험 뿐이라서요.

하여간 궁금합니다.
* 꼭 비싼 LSI 전용 케이블을 써야 하는 것인지, 아니면 일반적인 SFF-8643 to SFF-8639를 사용해도 되는 것인지
* 오리지날 LSI 9440-8i가 아닌 Lenovo 530-8i를 cross flashing한 것도 NVMe가 되는지
* 속도는 제대로 나오는지
     
송주환 02-20
미국에서 케이블을 주문해 뒀습니다. 늦어도 다음주에는 도착할 것인데, 동작하지 않는다면 대략 난감하겠네요.
그리고 링크 걸어주신 Tri-mode 케이블 이야기는 Backplane의 pinout이 다르다는 이야기로 보입니다.
     
송주환 02-24
후기와 도큐먼트를 쭉 살펴보니 u.2 Enabler 케이블이 필요한 것이 맞네요.
속도 이슈는 후기를 기다려봐야 할 것 같습니다
간장게장 02-26
정리
* LSI 9400 계열(9400, 9440, 9460)에서 NVMe를 사용하려면 일반적인 SFF-8643 to SFF-8639를 사용할 수 없고, LSI의 전용 케이블 혹은 그것과 호환되는 케이블을 사용해야 한다.

LSI의 케이블은 HBA 쪽은 x8 SFF-8643 즉 SFF-8643 2 포트를 한꺼번에 끼우는 식이고 다른 쪽은 SFF-8639 U.2 2 포트

9400-8i는 (1) 2개의 NVMe 혹은 (2) 8개의 SAS/SATA를 연결할 수 있고
9400-16i는 (1) 4개의 NVMe 혹은 (2)  2개의 NVMe + 8개의 SAS/SATA 혹은 (3) 16개의 SAS/SATA를 연결할 수 있다.
(x4 NVMe가 아닌 x2 NVMe를 사용한다면 NVMe 갯수는 2배로 증가하는데 케이블 같은 것은 아직 알 수 없음.)

* LSI 9460-8i, 16i에서는 NVMe에서 기대되는 속도가 나옴. raid 가능
no-read ahead, write through, direct-io로 설정해야 random 속도가 제대로 나옴(SATA/SAS SSD도 마찬가지)

* Lenovo 530-8i에 LSI 9400 firmware를 입힌 것도 NVMe 사용 가능)

한가지 남아있는 것은 530-8i를 cross flashing한 경우 어떤 한 사람의 테스트 결과는 성능이 저조하게 나왔다는 것. PCIe 아답터 사용한 경우에는 제대로 나옴.
한사람의 테스트 결과이므로 다른 사람들의 확인이 필요함




제목Page 4/251
2014-04   2479011   회원K
2015-12   11702   백메가
02-19   2129   캔위드
02-17   1555   송주환
02-14   2024   song05
02-13   1963   라면좀먹자
02-12   1215   메모리님
02-12   1363   페르세우스
02-07   1765   차넷컴퓨터
02-06   1513   제이레빗
02-02   2310   이준용
02-01   11104   스캔
02-01   2931   페르세우스
01-26   2516   Jasper
01-23   2057   박건
01-20   2977   생겼으면
01-16   2920   이라달
01-11   3440   길가던뉴비
01-11   3186   죽림칠현
01-10   2469   판타지스타
2018-12   2996   루비믹스
2018-12   2503   Doker