[Mikrotik] VPN PPTP방식 Point to Point 연결 - IP 수동할당

   조회 8335   추천 0    

강좌 게시판에 이진님께서 올리신 자료가 있는데...

VPN PPTP방식 Point to Point 연결 - IP 자동 할당 

VPN PPTP방식 Site to Site 연결

제가 사용한 방식은
Point to Point 연결로 PPTP방식의 VPN을 구성하고...
VPN연결을 하는 사용자의 ID당 IP를 부여해 VPN 연결자의 IP를 고정시키는 방식입니다.

해당 설정은 이진님께서 강좌글을 올리시기 전에 설정한 것으로...
구글링으로 배우고 이해한 것을 이진님의 설정과 비교하여 설정값에 대한 대락적인 설명을 첨부했습니다^^;

해당 설정은 
내부 아이피가 192.168.121.1/24으로 미크로틱 IP가 192.168.121.1으로 되어있으며 
ether1에 WAN, ether2~5가 내부랜으로 작동하고 
ether2를 Master Port로 ether3, ether4, ether5가 설정되어 있는 RB450G를 기준으로 작성되었습니다



Step 1. 네트워크 검색으로 다른 PC 검색기능을 활성화 하기...

1.1 터미널 명령어

/interface ethernet 
set 1 arp=proxy-arp 
set 2 arp=proxy-arp 
set 3 arp=proxy-arp 
set 4 arp=proxy-arp 

### 설명 ###
set 뒤의 숫자는 터미널에서 /interface print 명령어를 넣어주시면 
쉽게 Winbox상에 보이는 Name값을 통해  #값을 찾아 확인이 가능합니다.
( # 항목 값이 0번 부터 시작을 해서 ether1에 WAN으로 연결된 것이 0번입니다.)
 
DHCP방식을 사용하는 이진님의 방식에서는 set 0 arp=proxy-arp으로 ether1만 설정하셨는데...
제가 설정했던 방법으로는 이상하게 작동을 안해서 나머지들 모두 바꾸니 네트워크 목록이 검색되어 나오더군요;
(아마 Step 2의 설정에서 ISP DNS, 공인 IP값으로 넣어준 부분의 차이로 보입니다.)


1.2 WinBox 사용

Interface 탭에서 ether2, ether3, ether4, ether5의 각 설정의 ARP 값을 proxy-arp로 변경...

### 설명 ###
내부네트워크에서 설정시 Master Port로 지정된 ether2의 설정을 변경할때 WinBox의 연결이 끊깁니다. 



Step 2. VPN 연결에 대한 프로파일 설정

2.1. 터미널 명령어

/ppp profile 
add change-tcp-mss=yes dns-server=192.168.121.1 \
local-address=192.168.121.1 name=VPN-PPTP use-encryption=yes 

### 설명 ###
change-tcp-mss : TCP MSS(Maximum Segment Size)를 활성화
dns-server : 이진님의 설정에서는 ISP의 DNS를 사용하셨는데... 
  전 그냥 미크로틱 IP로 설정했습니다. ( 기본값 192.168.88.1)
local-address : 이진님의 설정에서는 미크로틱의 공인IP를 사용하셨는데...
  이것도 미크로틱 IP로 설정했습니다.  ( 기본값 192.168.88.1)
use-encryption : VPN 연결시 전송되는 데이터를 암호화
                       이 때문에 일전에 테스트때 속도가 약간 떨어진 것 같기도 합니다.

명령어 2번째줄 끝의 "\"는 연속된 명령어로 입력해야 하는 상황에서
하단의 내용을 연속된 내용으로 인식시키기 위해 삽입 되었습니다.

좀 더 자세한 설정 값에 대한 확인은 아래 링크를 확인하세요.


2.2 WinBox 사용

PPP 메뉴에 들어가 Profiles에서 + 버튼을 눌러 아래와 같은 설정 값을 넣어주세요.






Step 3. PPTP 서버 사용 및 인증프로토콜 설정

3.1. 터미널 명령어

/interface pptp-server server 
set authentication=pap,chap,mschap1,mschap2 \
default-profile=VPN-PPTP \
enabled=yes 

### 설명 ###
authentication : 인증프로토콜 4가지를 모두 허용, 윈도우에서는 mschap2 인증이 기본값입니다.
default-profile : Step 2.에서 설정한 프로파일을 사용하게 하시면 됩니다.

명령어 2번째, 3번째 줄 끝의 "\"는 연속된 명령어로 입력해야 하는 상황에서
하단의 내용을 연속된 내용으로 인식시키기 위해 삽입 되었습니다.

좀 더 자세한 설정 값에 대한 확인은 아래 링크를 확인하세요.


3.2 WinBox 사용

PPP 메뉴에 들어가 Interface 탭에서 PPTP Server를 클릭해 이미지와 같이 설정해 주세요.




Step 4. PPTP에 연결할 계정 생성 및 계정에 대한 IP 설정

4.1. 터미널 명령어

/ppp secret 
add name=test password=1234 \
service=pptp profile=VPN-PPTP \
remote-address=192.168.121.200

### 설명 ###
name : VPN 연결 계정의 ID값
password : VPN 연결 계정의 비밀번호
service : 해당 계정이 어떤 VPN 방식에서만 사용하는지 지정해 줍니다.
     해당 설정이 빠져도 기본값이 any으로 모든 방식에서 사용됩니다.
profile : Step 2.에서 설정한 프로파일을 사용하게 하시면 됩니다만... 
     해당 설정이 빠져도 PPTP Server에 방식이 저장되어 있어서 별 상관은 없습니다.
remote-address : 외부에서 PPTP 연결 후 내부 네트워크들에 접속할때 해당 IP로 인식되고 
                         내부에서 PPTP 연결 후 내부 네트워크들은 기존 연결 IP로 인식됩니다.

명령어 2번째, 3번째 줄 끝의 "\"는 연속된 명령어로 입력해야 하는 상황에서
하단의 내용을 연속된 내용으로 인식시키기 위해 삽입 되었습니다.

좀 더 자세한 설정 값에 대한 확인은 아래 링크를 확인하세요.

4.2 WinBox 사용

PPP 메뉴에 들어가 Secrets에서 + 버튼을 눌러 아래와 같은 설정 값을 넣어주세요.




p.s 1.
타이핑 몇줄이;;;

p.s 2.
웹으로 현재 연결의 공인 IP 확인은...
CMD 명령어와 같은 도메인네임을 가진 아래 사이트에서 쉽게 확인이 가능합니다.


p.s 3.
VPN 연결시 모든 네트워크 통신 방향이 접속하는 클라이언트의 게이트웨이 설정에 따라 2가지 방식으로 진행됩니다.

1.  VPN접속지 -> 인터넷 -> VPN서버  -> 타겟 (인터넷 웹페이지, 로컬 네트워크)
2.1.  VPN접속지 -> 타겟 (인터넷 웹페이지)
2.2   VPN접속지 -> 인터넷 -> VPN서버  -> 타겟 (로컬 네트워크)  

윈도우에서 기본 설정으로는 1번 방식으로 연결이 되는데...
인터넷 웹페이지 접속 IP를 굳이 VPN서버 위치로 속일 필요가 없으시면 2번 방식으로 설정하시는게 더 좋다고 봅니다.
해당 설정법은 아래와 같이 변경하시면 됩니다.

 1. "제어판\네트워크 및 인터넷\네트워크 연결" 에 접속 생성한 VPN 연결의 속성 메뉴

2. 네트워킹 탭 -> TCP/IPv4 선택 -> 속성

3. 고급버튼 클릭

4. "원격 네트워크에 기본 게이트웨이 사용" 체크 해제

회원K 2014-04
감사합니다. 눈에 팍팍 들어옵니다^^
     
Step 2.2의 두번째 이미지에서 탭 선택 형광표시부분이 잘못되었는데... 감안하시고 보세요^^;
글을 수정하려고 해보니..
댓글 있는 글은 수정이 불가능하다고 팝업창이 나옵니다.
     
대장님이 빠르게 수정해 주셔서 이미지 수정했습니다
http://www.2cpu.co.kr/bbs/board.php?bo_table=freeboard_2011&wr_id=214558
양영훈 2014-08
PPTP 설정하는데 많은 도움 되었습니다.
고맙습니다~^^

저의 상황에서 설정하는 분이 계실 것 같아서... 약간만 덧 붙이면...
저 같은 경우 브릿지 모드로 연결한 상태라...
스텝 1의 proxy-arp 모드는 브릿지에만 적용하니까 파일 공유가 되었습니다.

그리고 사이트 접속 우회를 위해 VPN이 필요한 상황이라
스텝 2의 설정은 ISP의 DNS와 공인IP를 넣어주는 것이 사이트 접속이 원활하였습니다.
참고하시기 바랍니다.




제목Page 44/46
2014-05   9044   눈빛마음
2014-05   7072   김은호
2014-05   8985   s김종화z
2014-05   5994   김장우
2014-05   5504   s김종화z
2014-05   4206   회원K
2014-04   7519   s김종화z
2014-04   6957   회원K
2014-04   4647   s김종화z
2014-04   4311   권영현z
2014-04   3737   회원K
2014-04   13389   Nicoffeine
2014-04   3064  
2014-04   5087   s김종화z
2014-04   7007   황혼을향해
2014-04   8336   HEUo김용민
2014-04   4360   빠시온
2014-04   5601   회원K
2014-04   3326   회원K
2014-04   2880   회원K