MikroTik 장비랑 KT IPTV 연동이 안되네요.

유사용   
   조회 2784   추천 0    

이번에 KT 올레 IPTV를 설치 했습니다.

MikroTik RB951G-2HnD 장비에 IPTV 관련 셋팅을 했지만 안되고 있어서요.

펌웨어는 최신인 v6.38 입니다.

집내의 배전반에 전기가 안되서 POE를 연결하였습니다.


KT 장비 - poe 연결 ------ RB951G-2HnD

1번 - WAN

2번 - 

3번 - PC

4번 - IPTV용 셋탑박스 ---- TV

5번 -

위와 같이 연결되어 있습니다.

IGMP Proxy 관련셋팅을 하면 된다고 하여 셋팅을 하였지만 TV 화면이 나오질 않네요.

기본 설정 (192.168.88.x) 에서 크게 변경한건 없습니다. (무선 PW 나 수정하지.. 나머진 그대로 입니다.)

혹 IPTV 를 볼려면 다른부분을 수정해야 되나요?

아래와 같이 추가 했습니다. 

/routing igmp-proxy interface add comment="" disabled=no interface=ether1 threshold=1 upstream=yes
/routing igmp-proxy interface add comment="" disabled=no interface=ether2 threshold=1
/routing igmp-proxy interface add comment="" disabled=no interface=ether3 threshold=1
/routing igmp-proxy interface add comment="" disabled=no interface=ether4 threshold=1
/routing igmp-proxy interface add comment="" disabled=no interface=ether5 threshold=1
/routing igmp-proxy mfc add source=192.168.88.1 upstream-interface=ether1 downstream-interface=ether4 group=224.10.10.11 disabled=no

/ip firewall filter add chain=input comment="Allow IGMP" in-interface=ether1 protocol=igmp


이태욱 01-05
KT는 IGMP 설정 해제 하시고 마스터 슬레이브 설정하셔서 공인 IP 가지고 오게 구성하셔야 합니다.
     
혹시 말씀 하시는게,
 별도의 독립적인 Bridge로 잡고, dhcp client로 public IP를 할당 받는 걸 말씀하시는지요 ?
          
이태욱 01-05
말씀하시는 구현 방법으로 가능은 하나 시스템에 부하가 많이걸립니다.
MikroTik 사 제품은 부(WAN)포트를 마스터로 설정한 상태에서 모(IPTV) 설정을 하여 스위칭 기능을 구현할 수 있습니다.
제 말은 WAN포트를 하나 더 만들어 IPTV가 WAN에 직접 물려있는 상황을 만들어 주는 겁니다..
http://wiki.mikrotik.com/wiki/Manual:Switch_Chip_Features
기능을 참고하시고. 가능하다면 6.37 이상의 버전을 사용하길 바랍니다.
유사용 01-05
혹시 cli 명령어 알수 있을까요?
마스트/슬레이브 설정이란게 정확히 무엇을 뜻하는건가요?
     
이태욱 01-05
     
이태욱 01-05
설정 예제
#RouterOS 6.20를 기준으로 작성되었습니다.
#MikroTik은 특성상 IOS가 업데이트 될때마다 일부 CLI 구문 또는 옵션이 고지 없이 변경되는 경우가 있습니다. 필히 적용 완료 상태를 export 명령을 통해 확인하셔야 합니다.
#ether3 - Master Port로사 용할 포트로서 Bridge에 가입 하지 않습니다.
#ether4 - Slave Port 설정할 포트 (마찬가지로 Bridge 가입 되어 있으면 안됩니다.)
/interface ethernet
set [ find default-name=ether4 ] master-port=ether3
## 설정 해석 -> [디폴트 인터페이스 이름이 ether4인 인터페이스를 찾아] 마스터 포트를 ether3로 "설정"합니다.

근데 이런건 트루네트웍스 기술지원센터가 더 잘해줄텐데요...^^
유사용 01-05
기본셋팅인 ether2-master에서 변경하여 ether1을 master 로 잡아서 ether4 + ether1로 잡고 나머지를 bridge에 넣어서 셋팅 하니 잘되는거 같네요 ㅎ
정말 감사합니다.
     
1. ether1-master + ether4-slave, bridge에 ether1-master를 추가하신 구성 인지요 ?
아니면, ether1/4를 port switch 구성 및 ether2/3/5를 bridger 구성하신건지 궁금합니다.

2. 성공하신, 관련 설정 (IGMP 포함) 부탁 드려도 될런지요
유사용 01-06
/interface ethernet
set [ find default-name=ether4 ] master-port=ether1

/interface bridge port
add bridge=bridge comment=defconf interface=ether2
add bridge=bridge comment=defconf interface=wlan1
add bridge=bridge interface=ether3
add bridge=bridge interface=ether5

이거 2가지가 제일 중요한거네요.
IGMP 관련 내용은 다 지워버렸습니다.
기본인 ether2 master 를 제거 하고요.
     
답변 감사드립니다 꾸벅
cclim 01-06
공인아이피가 아니라도 KT IPTV 시청에는 문제 없습니다. VOD에서는 공인아이피가 필요하다는 이야길 보긴했습니다.
저는 pfsense로 아래 링크처럼 설정하고 셋톱과 Tvheadend 모두 사용중 입니다.
http://www.2cpu.co.kr/network/1756
     
Internet(공인 IP #1) ---- Mikrotik ---- IPTV (공인 IP #2)
                                      |
                                      |
                                      Synology (TV Headend, 사설 IP - NATed with 공인 IP#1)

이런 구성으로, TV Headend가 가능할런지요 ?
          
cclim 01-07
tvheadend는 공인ip와 상관없이 igmp 프록시만 잘 되면 됩니다.




제목Page 1/0
게시물이 없습니다.