미크로틱 RB2011에서 KT VOD, tvheadend(IGMP) 둘 다 사용하기

   조회 496   추천 0    

안녕하세요.

일전에 이 곳에 미크로틱 RB2011 질문 올리고 구매하여 세팅중입니다.

인터넷 포트 변경(eth1 -> eth6), 내부 고정ip 설정, 포트포워딩, guest wifi (가정집에 웬ㅋㅋㅋ) 까지 차근차근 해보았습니다.

헤어핀 NAT 문제도 처음 알게 되었네요. (미크로틱 문서는 공인IP가 static인 경우라 저는 이 링크 보고 해결했습니다)


본론입니다. 미크로틱 RB2011에서 KT VOD와 IGMP 둘 다 사용하도록 설정해서 현재 둘 다 잘 나옵니다만.

IPTV 스트림이 LAN에 broadcast 되는걸 막고 싶고, LAN은 하드웨어 스위칭이 되길 원합니다.

현재 세팅에서는 ether2에 있는 tvheadend가 녹화를 하면 아래처럼 LAN에 broadcast 됩니다. 6.41부터 제공하는 IGMP Snooping을 켜면 broadcast 문제가 없어집니다만, LAN 전체가 소프트웨어 스위칭으로 바뀌어 파일 전송만 해도 CPU 로드가 팍팍 오릅니다.


어떤 방법이 있을까요?

a. LAN bridge가 아닌 ether2에만 쏘면 좋겠는데요. 브리지 대신 ether2를 등록하면 igmp-proxy가 Inactive되네요.

b. LAN으로 broadcast 되는 패킷을 필터링해서 ether2를 제외하고 drop시킬까 했는데, 어떻게 설정해도 안 되네요.

c. 기타 아이디어...


현재 설정은 이렇습니다. Router OS는 6.42.6 이고 multicast package 설치했습니다.

/routing igmp-proxy interface

add alternative-subnets=0.0.0.0/0 interface=br-wan-stb upstream=yes

add interface=br-lan

/interface bridge

add name=br-lan admin-mac=**:**:**:**:**:** auto-mac=no

add name=br-wan-stb

/interface bridge port

add bridge=br-lan interface=ether1-ap  --- 미크로틱 cAP ac2

add bridge=br-lan interface=ether2      --- tvheadend 돌리는 피씨

add bridge=br-lan interface=ether3     --- 기타 유선 기기들...

add bridge=br-wan-stb interface=ether6-wan  --- KT인터넷 100M

add bridge=br-wan-stb interface=ether7-stb  --- 셋탑박스 == iptime의 KT iptv전용 포트


* br-wan-stb는 WAN과 셋탑박스 연결 브리지인데, hw-offload 표시됩니다. Router OS 6.41 부터는 master/slave 설정이 없어졌네요. [문서]

Note: Since RouterOS v6.41 the master-port configuration is removed and replaced with a more simplified bridge configuration. The same functionality can be achieved by adding ports to a bridge with hardware offloading enabled and ensuring that protocol-mode is set to RSTP.

빠시온 08-07
미크로틱은 다 좋은데 IPTV랑 너무 맞추기가 힘들어요..

뭐 IGMP까지 업데이트해서 제공해주니 너무 불만 가질건 아니긴 하지만요 ㅎㅎ
한 가지 방법 찾았습니다. b에 해당하는 방법으로 보면 되겠네요.
브리지에 포트 추가할 때, unknown-multicast-flood 옵션을 꺼버리는 방법이 있네요.
프로토콜 예제 중 mDNS 정도가 맘에 걸리네요. 아마 안 쓰는 것 같지만요.

https://wiki.mikrotik.com/wiki/Manual:Interface/Bridge
# unknown-multicast-flood (yes | no; Default: yes)
When enabled, bridge floods unknown multicast traffic to all bridge egress ports. When disabled, drops unknown multicast traffic on egress ports. Requires igmp-snooping=yes to be set to work properly. Multicast addresses that are in /interface bridge mdb are considered as learned multicasts and therefore will not be flooded to all ports. Without IGMP Snooping all multicast traffic will be dropped on egress ports. Has effect only on an egress port. This option does not limit traffic flood to the CPU. Note that local multicast addresses (224.0.0.0/24) are not flooded when unknown-multicast-flood is disabled, as a result some protocols that rely on local multicast addresses might not work properly, such protocols are RIPv2m OSPF, mDNS, VRRP and others. Some protocols do send a IGMP join request and therefore are compatible with IGMP Snooping, some OSPF implementations are compatible with RFC1584, RouterOS OSPF implementation is not compatible with IGMP Snooping.




제목Page 1/38
08-16   207   재마
08-16   214   재마
08-16   394   쿨파스
08-15   310   리얼메카
08-14   213   회원K
08-14   282   회원K
08-14   190   회원K
08-14   229   크리보
08-12   279   그냥중
08-11   497   홈서버가동중
08-10   656   재마
08-09   372   오한량
08-08   602   회원K
08-07   497   탱쟈가라사대
08-04   895   오한량
08-03   758   스린
08-01   777   민달팽이
07-29   1854   민달팽이
07-28   729   Galvanizer
07-14   1784   SMN920T