미크로틱 L2TP VPN 서버 설정

느낌   
   조회 642   추천 0    

미크로틱 CCR1009 에 KT 광모뎀에서 나온 회선3개를 물렸습니다.(공인 IP가 여러개 필요)

LAN포트에 허브를 설치 하였고 이하 내부 내트워크(192.168.1.0/24)에 여러 서버랑 데탑 등이 있는 환경입니다.

사무실에서 집에 있는 내부네트워크 환경이 필요해서(네트웍 드라이브 연결) VPN 서버를 설치를

구글검색을 하여 해보았는데 Router OS 버전이 이전 버전에서 설정한 내용들이라 실행하면 설치가 안되고 에러가 발생하더군요.


/interface ethernet set [default-name=ether1] arp=proxy-arp name=LAN

/interface l2tp-server server set authentication=mschap1,mschap2 default-profile=ipsec_vpn enabled=yes




/ppp profile add dns-server=168.126.63.1 local-address=192.168.1.1 name=ipsec_vpn  remote-address=VPN-pool use-encryption=yes

/ppp secret add name="사용자이름" password="패스워드" profile=ipsec_vpn remote-address=192.168.1.151 service=l2tp





/ip ipsec peer add name=l2tpserver passive=yes

/ip ipsec proposal set [ find default=yes ] enc-algorithms=3des lifetime=1d

/ip ipsec identity add generate-policy=port-override peer=l2tpserver secret="시크릿"

/ip ipsec policy set 0 dst-address=0.0.0.0/0 src-address=0.0.0.0/0











/ip firewall filter add action=accept chain=input comment=VPN port=1701,500,4500 protocol=udp

/ip firewall filter add action=accept chain=input protocol=ipsec-esp


ip pool은 DHCP서버에서 할당 받는 주소랑, VPN서버에 접속시 받는 주소 pool을 아래와 같이 둘로 하였습니다.

/ip pool add name=dhcp ranges=192.168.1.2-192.168.1.250

/ip pool add name=VPN-pool ranges=192.168.1.251-192.168.1.254

* 접속하면 항상 192.168.1.151로만 되는거 같내요. ㅠㅠ

PPP Profile에서는 Remote address에 VPN-pool이 가능한데, PPP Secret 설정에 Remote Address에는 VPN-pool을 입력이 안되고
주소만 가능하내요. 그래서 그런듯 합니다.


일단, 아이폰에서 접속시 아래와 같이 잘 됩니다.

(WAN IP 주소 3개 중 아무거나 접속해도 됩니다)




폰에서 속도는 LTE에서는 260Mbps나오는데  VPN으로 연결시 40Mbps 정도 나오내요.






빠시온 04-07
l2tp가 그나마 잘나오고 나머진 그닥....

CCR인데 VPN 성능은 영 ....
     
느낌 04-07
미크로틱이 원래 그런거군요..ㅠㅠ
방안에 있는 kt와 sk 500메가 사이에 kt는 ccr1009 sk는 850gx2로 해서 ipsec 380메가 나옵니다.
망 상황에 따라 다른거겠죠
     
느낌 04-20
세팅 후 처음으로 다른 곳에서 해보니 그곳 인터넷이 100M 환경인데 속도가 90M 이상으로 나오더군요.
망 상황에 따라 다른거 같습니다. 밖에서 접속해도 집안에서 접속한 느낌이 듭니다.
너무 마음에 드내요 ^^




제목Page 1/45
00:55   56   훔냥이
04-24   144   겜돌맨
04-24   180   Malice
04-23   134   김명자낙지…
04-23   211   leon0207
04-22   346   leon0207
04-20   532   SiCMOS
04-18   564   잘하자
04-16   504   po2481
04-15   741   김황중
04-15   482   po2481
04-15   335   EndtoEnd
04-10   940   잘하자
04-10   1148   윤민수
04-08   935   po2481
04-08   842   윤민수
04-07   643   느낌
04-07   901   비트
04-01   1372   김현우1
04-01   921   봉팔e