mikrotik ¿¡¼­ dyndns ÀÚµ¿ IP ¾÷µ¥ÀÌÆ® ver 2

Leo   
   Á¶È¸ 7118   Ãßõ 0    

아래 dyndns 자동 업데이트 스크립트를 살짝 바꿔서
dyndns 에 2개의 hostname 을 등록했을때 2개 모두 업데이트 하도록 하는 스크립트를 만들어 봤습니다.

:local username "<dyndns id>";
:local password "<dyndns password>";
:local hostname { "first"="<dyndns hostname1>"; "second"="<dyndns hostname2>" }
:local inetinterface "ether1-gateway";
:local sysdate [/system clock get date];
:local systime [/system clock get time];
:local sysname [/system identity get name];

:local dyndnsForce;
:set dyndnsForce false;

# Print debug info
#:log info ("DynDNS: username = $username");
#:log info ("DynDNS: password = $password");
#:log info ("DynDNS: hostname1 = $hostname->first");
#:log info ("DynDNS: hostname2 = $hostname->second");

# Check if WAN interface is running
:if ([/interface get $inetinterface value-name=running]) do={

# Get the current IP on the WAN interface
    :local currentIP [/ip address get [find interface="$inetinterface" disabled=no] address];

# Strip the net mask off the IP address
    :set currentIP [:pick $currentIP 0 [:find $currentIP "/"]];
    :log info ("DynDNS: current WAN IP = $currentIP");

# do loop for all hostname
    :foreach key,value in=$hostname do={

# Get resolved IP for hostname
        :local resolvedIP [:resolve domain-name=$value server=8.8.8.8];
        :log info ("DynDNS: resolved IP for $value = $resolvedIP");

# Determine if dyndns update is needed
        :if (($currentIP != $resolvedIP) || ($dyndnsForce = true)) do={
            :set dyndnsForce false;
            /tool fetch user=$username password=$password url="http://members.dyndns.org/nic/update\?hostname=$value&myip=$currentIP&wildcard=NOCHG&mx=NOCHG&backmx=NOCHG" dst-path="/dyndns.txt";
            :delay 1;
            :local result [/file get dyndns.txt contents]
            :log info ("DynDNS: update needed for $value")
            :log info ("DynDNS: update result for $value = ".$result)
        } else={
            :log info ("DynDNS: no update needed for $value");
        }

# end of loop for all hostname
    }

# if WAN interface is not running
} else={
    :log info ("DynDNS: $inetinterface is not currently running");
}

mikrotik 으로 스크립트 프로그램 짜는 것도 은근 재밌군요. :)


Á¦¸ñPage 104/104
06-29   4680   archetype
07-05   3308   ckzkdsyd2
07-08   2571   ´Ùºñ´Ï
07-08   3508   ZGERO
07-10   3188   iaj04
07-17   3048   ¿ìÁÖ¼Ò³â
07-18   4723   chotws
07-18   5547   ³×¿¡¿¨Æ®Æ®¡¦
07-19   6074   ¾È³çÇØ¿ä
07-24   5661   ´Ð³×ÀÓ
07-26   5840   ¹öµé68
07-30   5271   Ä«ÀÌÁ¦¸°
08-05   3535   °Ç¼ö¼±°æ¾Æºü
08-13   2179   attention0
08-16   2854   krDeveloper
08-17   2980   attention0
08-22   3069   ÀÓÇÁ·Î
08-22   3330   ºê¶ó¿î½º
08-23   3402   ¾ÆÀ̾¾Æ¼
08-23   3536   ÆÒ´õ°í¶ó´Ï