[Server] R510 ipmitool 명령어 안될때 해결방법 및 펜속조절에 따른 소음확인 영상

캔위드   
   조회 1215   추천 1    

ipmitool 다운로드 및 설치

https://www.dell.com/support/home/kr/ko/krbsd1/product-support/product/poweredge-r510/drivers 


설치하면 C:\Program Files (x86)\Dell\SysMgt\bmc 경로에 ipmitool.exe 파일이 생깁니다.

경로 자동으로 PATH 추가되지 않으니 수동으로 PATH 추가하거나 bmc폴더로 이동한 다음 ipmitool 명령어를 사용합니다.


문제해결

문제는... 실제로 실행하면 이리 된다는거 ㅠ

이 메세지가 나오는 원인은 이유가 무엇이든 결국 접속이 실패한 경우입니다.

비밀번호를 틀렸거나 IP가 틀렸거나 어쨌든 접속 못한경우;

그래서 http://192.168.0.120/ 으로 root / calvin 으로 접속이 잘 되는데 ipmitool 명령어만 안먹힌다 ? 그럴때

해결방법

우선 bios하고 idrac firmware 를 최신으로 업데이트 합니다.

BIOS_PYCXX_WN32_1.14.0_01.EXE

ESM_Firmware_KPCCC_WN32_2.92_A00.EXE


그리고 ipmi 들어가서 다음 옵션에 체크합니다.


그럼 명령어가 아주 잘 먹습니다;


영상으로 찍어봤습니다.




명령어 : 출처 -- http://2cpu.co.kr/hardware_2014/42230


[ 펜속 수동모드 설정 ]

켜기 ipmitool -I lanplus -H 192.168.0.120 -U root -P calvin raw 0x30 0x30 0x01 0x00

끄기 ipmitool -I lanplus -H 192.168.0.120 -U root -P calvin raw 0x30 0x30 0x01 0x01


[ 펜속도 설정 ]

00% ipmitool -I lanplus -H 192.168.0.120 -U root -P calvin raw 0x30 0x30 0x02 0xff 0x00

20% ipmitool -I lanplus -H 192.168.0.120 -U root -P calvin raw 0x30 0x30 0x02 0xff 0x14

30% ipmitool -I lanplus -H 192.168.0.120 -U root -P calvin raw 0x30 0x30 0x02 0xff 0x1e

50% ipmitool -I lanplus -H 192.168.0.120 -U root -P calvin raw 0x30 0x30 0x02 0xff 0x32

70% ipmitool -I lanplus -H 192.168.0.120 -U root -P calvin raw 0x30 0x30 0x02 0xff 0x46

80% ipmitool -I lanplus -H 192.168.0.120 -U root -P calvin raw 0x30 0x30 0x02 0xff 0x50



영상을 보면 아시겠지만

00% ipmitool -I lanplus -H 192.168.0.120 -U root -P calvin raw 0x30 0x30 0x02 0xff 0x00

(빨간색) 부분을 1단위로 변경해 가며 소음과 온도 사이의 절충점을 찾아서 셋팅하면 될 것 같습니다.

또한 dos 명령어이기 때문에 스케줄 걸어놓고 사람이 없는 시간에 가령 여름같은 경우 사람 없을땐 에어컨도 끌테니

그 시간 맞춰서 스케줄 설정해서 쎄개 돌리는 것도 방법일 것 같습니다.



이럴 줄 알았으면 여러개 지르는건데... 다음에 올라오면 두어개 더 질러야겠습니다. ㅎㅎ


짧은글 일수록 신중하게.
리눅서 03-27
새벽에 고생하시네요 ㅎㅎ 저는 귀찮아서 그냥 디폴트로 두고 쓰는데 다음에 캔위드님 글 참고해서 세팅좀 건드려봐야겠군요
R510 곧 오니 팬 소음이 심하면 시도 해 보겠습니다.. 정말 감사합니다!
간장게장 03-27
당연한 이야기이지만 낮은 속도로 세팅했을 때는 그 환경에서 몇 시간 후에 온도가 괜찮은지 확인해 보아야 합니다.
특히 여름에
어꾸기 04-10
저도 모든 세팅 다하고 껐다가 아침에 다시 켜니.. 소음이 다시 커지더군요.(재시작이 아닌 종료 후 시작)
그냥 batch 파일 하나 만들어서 서버 껐다가 켜며 자동 로딩되게 했더니 완전 종료했다가 켜져도 조용합니다.




제목Page 5/261
2014-05   3048977   정은준1
2014-04   2743763   회원K
04-01   1139   김은호
03-31   1397   kb0723
03-30   1368   캔위드
03-30   1507   캔위드
03-27   1216   캔위드
03-24   1114   Lucifer
03-23   1121   원주멋진덩치
03-23   1533   박수형
03-18   1842   오징어따콩
03-10   2033   윤하쨔응
03-09   1590   캔위드
02-29   1933   모어쿨
02-26   2630   캔위드
02-26   2445   스린
02-25   2325   DaVinci
02-22   1318   SiCMOS
02-20   3448   강프로
02-18   2074   HEUo김용민
02-14   2643   Dominozlol
02-13   2815   수퍼싸이언