[Hyper-V] SSD 속도 관련 문제

Lucyed   
   조회 1369   추천 0    

 


현재 사진에 있는거 외에도 많은 가상화를 돌리고 있고 

4 개정도의 SSD가 장착 되어있습니다.

그런데 크리스탈 디스크 를 체크해보니 속도가 제대로 나오지 않아 질문드립니다.


C 드라이브 


D 드라이브


G 드라이브


I 드라이브

 



D드라이브는 제외 하고 모두 Micron MX200 모델입니다.

레이드는 묶지않고 하드 인식만 되게 따로따로 해둔 상태입니다.

가상화로 사용중에 있는 SSD는 속도체크를 해도 속도가 제대로 나오지 않는걸까요? 

아니면 어디에 문제가 있는걸까요? 

SSD의 수명? 레이드 컨트롤 카드?

AHCI 모드로 변경하면 정상으로 돌아올까요?


호스트 AHCI 는 SSD,HDD 불문 켜주시는게 좋습니다.

질문이 베어메탈 환경에서 디스크마크가 잘 안나오는건지
VM에서 잘 안나오는건지는 모르겠습니다.

베어메탈에서 해당 성능밖에 안나오는거면 mx200이 Sata2에 물려있을 가능성이 높습니다. (아니면 sata2 모드이거나)

또한 디스크 마크를 실행하는 드라이브에 프로그램이나 VM이 실행중이라면 당연히 성능은 잘 안나오게 보이는게 정상입니다.
완전히 디스크를 사용하지 않는 상태에서 다시 시도해보세요.

VM에서의 경우에는

VM에서 디스크 퍼포먼스가 100% 안나오는건 전가상화, 반가상화(virtio 같은) 방식이던 베어메탈 퍼포먼스를 낼 수 없기 때문입니다.

Hyper-V 는 많은 하이퍼바이저들 중 디스크 퍼포먼스가 잘 나오는 축에 속하기에 실사용은 문제 없을겁니다.
VM에서 베어메탈에 준하는 성능을 내시려면 하이퍼바이저 튜닝이 필요합니다.

그럼에도 랜덤 I/O 성능을 감안하면 다중 VM 환경에서 SSD를 사용하는게 훨씬 좋습니다.

실제 체감 성능은 디스크 벤치마크와 무관하게 양호한 수준일 겁니다.
     
Lucyed 01-30
추후 궁금한 것은 답글로 물어보겠습니다. 답변 감사합니다.
"AHCI 모드로 변경하면 정상으로 돌아올까요?"
지금 IDE모드신가요..? AHCI모드로 돌리시고 트림돌아가는 것 확인하신다음에.. 자동트림 활성화되어있는지 까지 확인/아니면 수동으로 한번 돌리시고..

해당 SSD는 써본적이 없어서 벤치를 찾아보니..(벤치는 VM내에서 돌리신것은 아닌것같으니..)
https://kbench.com/community/?q=node/6254 이 정도 속도는 나와야겠네요..
찾아보니 디램도 달려있는것 같고.. 전체적으로 상당히 낮게 찍히고 있는것은 확실해보입니다..




제목Page 3/86
2014-04   2443527   회원K
2015-12   11355   백메가
02-09   1146   빠시온
02-06   1382   주태형
02-05   1556   빠시온
02-01   1281   김동자맨
02-01   1569   민섭79
02-01   1217   승우아빠
02-01   1510   하늘색꿈
01-30   1370   Lucyed
01-29   1542   그림일기
01-29   915   박문형
01-28   910   서버나라
01-27   1176   스모모군
01-25   1111   chotws
01-22   1250   neojigi
01-22   1941   정열의꽃이…
01-20   1426   일리케
01-19   1548   김동자맨
01-19   1284   김동자맨
01-18   1461   헛비
01-14   2299   민빠돌